Instructure has reported to us that they rolled out a fix on November 21st to increase the provisioned concurrency of their Lambdas to handle a higher API load on their DAP API. We are continuing to follow up with them as Unizin observed issues with the DAP API until November 23rd.
Posted Dec 03, 2025 - 20:42 UTC
Update
We have continued to not see errors from Canvas's DAP API. Unizin has still not received an update on the permanent resolution for the underlying issue Instructure identified. We will continue to follow up with Instructure on this issue and provide any updates we receive.
Posted Dec 01, 2025 - 17:29 UTC
Monitoring
Over the weekend Unizin adjusted the configuration of all member's ingest jobs in an attempt to alleviate the errors we have been encountering from Canvas's DAP API. So far, the errors have not reappeared but Unizin will continue to monitor the status of all the Canvas Data ingest jobs to ensure fresh data is populated within the UDP in a timely manner.
Instructure has notified us that they are aware of the underlying issue and are working on a fix. No details about a permanent resolution have been shared yet. We will continue to provide updates as more information becomes available.
Posted Nov 24, 2025 - 20:38 UTC
Update
No errors occurred overnight when ingesting CD2 data via Canvas’s DAP API. We are still awaiting an update from Instructure regarding a permanent fix and will share more information as soon as it becomes available.
Posted Nov 21, 2025 - 17:22 UTC
Identified
Instructure has identified the root cause of the errors and is actively working on a solution. In the meantime, we are implementing their recommended workaround to reduce impact. We will continue collaborating closely with their team and will share further updates as more information becomes available.
Posted Nov 20, 2025 - 15:52 UTC
Update
We are continuing to see errors from Canvas’s DAP API that are affecting our data ingestion processes. We are working to keep new data moving into the UDP wherever possible. We have reached out to Instructure and are currently awaiting their response. We will share more updates as they become available.
Posted Nov 19, 2025 - 18:25 UTC
Update
We are still seeing intermittent failures with Canvas Data ingestion. Our team has engaged Instructure Support for further investigation and is actively working with them to identify the root cause. We will provide additional updates as more information becomes available.
Posted Nov 18, 2025 - 18:29 UTC
Update
Our team is still actively investigating the intermittent CD2 ingest failures. We will continue monitoring the ingest jobs overnight and will provide another update as soon as additional information is available.
Posted Nov 17, 2025 - 23:31 UTC
Investigating
We’re seeing intermittent failures when ingesting CD2 data from Instructure. As a result new Canvas data populating into the UDP may be delayed. Our engineering team is actively investigating the issue and will provide updates as more information becomes available.
Posted Nov 17, 2025 - 19:56 UTC
This incident affects: UDP - Batch ETL, UDP - Marts, and MyLA.