Delayed ingests due to CD2 API errors

Incident Report for Unizin Ltd

Resolved

Instructure has reported that the errors we saw were due to a temporary regional service outage in their API Gateway that has since been fixed.

We have reran the jobs that were missed due to these errors and all ingestion should run with fresh data going forward.
Posted Jun 01, 2026 - 16:06 UTC

Monitoring

Over the weekend, we observed elevated 503 errors from the CD2 API we use to be able to pull in fresh Canvas data to various datasets. As a result, data propagation has been delayed — from raw canvas* datasets through to the context store — with impact varying by institution.

As of today (June 1), errors have subsided. We are actively retrying the affected jobs and monitoring CD2 API responses to confirm stability.
Posted Jun 01, 2026 - 14:39 UTC
This incident affected: UDP - Batch ETL and UDP - Marts.