RedShelf eReader outage due to an ongoing AWS incident

Incident Report for Unizin Ltd

Resolved

RedShelf has reported that all systems are operational. Any additional status updated will be reported here and at https://status.redshelf.com/.
Posted Oct 20, 2025 - 19:56 UTC

Identified

Currently the RedShelf eReader is experiencing issues caused by an ongoing AWS incident.

You can follow the status of the issue at https://health.aws.amazon.com/health/status and https://status.redshelf.com/
Posted Oct 20, 2025 - 14:11 UTC
This incident affected: RedShelf eReader.